mpvue微信小程序引入SDK报错,帮忙看下,感谢

引入 视频通话/视频互动直播 SDK(微信小程序)
const AgoraMiniappSDK = require("…/…/lib/Agora_Miniapp_SDK_for_WeChat.js");

请确保不要二次编译 Agora SDK,另外 client 对象不要存在 mpvue 的 data 里。

我是直接解压后,把SDK js放到工程lib目录得,然后引入后,小程序编译报得上面得错误,还没有使用:smile:

好的,根据以往经验,这种问题一般是 IDE 配置项异常,和 SDK 无关。建议根据报错内容 检查下调试基础库的设置。

目前现象是这样得:

  1. 直接使用官网小程序语音视频demo是没问题得
  2. 用mpvue引入sdk,小程序编译会报错

应该是 mpvue 环境配置的问题,请检查一下 mpvue 基础库的配置。

“dependencies”: {

"less": "^3.10.3",

"less-loader": "^5.0.0",

"mpvue": "^2.0.0",

"style-loader": "^1.0.1",

"vuex": "^3.0.1"

}
请看下这个版本支持吗

我们也没有测试过这个框架,不确定是否可行。但是刚才 google 搜索了一下,发现也有其他开发者有相同的报错,建议联系写 mpvue 的工程师咨询看下是否有解决方案?
https://github.com/Meituan-Dianping/mpvue/issues/1574